Browse code

pkg: obs/kamailio.spec - set version to 5.4.0

- set packager to Sergey Safarov
- add more build requirements, including those from GH #2368

Daniel-Constantin Mierla authored on 23/06/2020 17:00:13
Showing 1 changed files
... ...
@@ -1,5 +1,5 @@
1 1
 %define name    kamailio
2
-%define ver 5.2.0
2
+%define ver 5.4.0
3 3
 %define rel dev1.0%{dist}
4 4
 
5 5
 %if 0%{?fedora}
... ...
@@ -238,11 +238,11 @@
238 238
 %endif
239 239
 
240 240
 
241
-Summary:    Kamailio (former OpenSER) - the Open Source SIP Server
241
+Summary:    Kamailio - the Open Source SIP Server
242 242
 Name:       %name
243 243
 Version:    %ver
244 244
 Release:    %rel
245
-Packager:   Peter Dunkley <peter@dunkley.me.uk>
245
+Packager:   Sergey Safarov <s.safarov@gmail.com>
246 246
 License:    GPL-2.0
247 247
 Group:      %{PKGGROUP}
248 248
 Source:     http://kamailio.org/pub/kamailio/%{ver}/src/%{name}-%{ver}_src.tar.gz
... ...
@@ -271,11 +271,20 @@ Conflicts:  kamailio-utils < %ver, kamailio-websocket < %ver
271 271
 Conflicts:  kamailio-xhttp-pi < %ver, kamailio-xmlops < %ver
272 272
 Conflicts:  kamailio-xmlrpc < %ver, kamailio-xmpp < %ver
273 273
 Conflicts:  kamailio-uuid < %ver
274
-BuildRequires:  bison, flex
274
+BuildRequires:  bison, flex, which, make, gcc, gcc-c++
275 275
 %if 0%{?rhel} != 6
276 276
 Requires:  systemd
277 277
 BuildRequires:  systemd-devel
278 278
 %endif
279
+
280
+%if 0%{?rhel} || 0%{?centos_ver}
281
+%if 0%{?rhel} > 6 || 0%{?centos_ver} > 6
282
+BuildRequires:  pkgconfig
283
+%endif
284
+%else
285
+BuildRequires:  pkgconfig
286
+%endif
287
+
279 288
 %if 0%{?suse_version} == 1315 || 0%{?suse_version} == 1330
280 289
 Requires:  filesystem
281 290
 BuildRequires:  shadow