Browse code

pkg/kamailio/deb: bionic can't use libssl1.0-dev due conflicts with libcurl4-openssl-dev dependencies

> The following packages have unmet dependencies:
> libcurl4-openssl-dev : Conflicts: libssl1.0-dev but 1.0.2n-1ubuntu5 is to be installed
> libssl-dev : Conflicts: libssl1.0-dev but 1.0.2n-1ubuntu5 is to be installed
> libssl1.0-dev : Conflicts: libssl-dev but 1.1.0g-2ubuntu4 is to be installed
> Unable to resolve dependencies! Giving up...

Victor Seva authored on 12/04/2019 12:52:55
Showing 6 changed files
... ...
@@ -42,7 +42,7 @@ Build-Depends:
42 42
  libsctp-dev,
43 43
  libsnmp-dev,
44 44
  libsqlite3-dev,
45
- libssl1.0-dev,
45
+ libssl-dev,
46 46
  libsystemd-dev,
47 47
  libunistring-dev,
48 48
  libxml2-dev,
... ...
@@ -25,8 +25,8 @@ sed -i -e '/^export JAVA_HOME/d' ${DIST}/rules
25 25
 sed -i -e 's/ java[ ,$]*/ /' ${DIST}/rules
26 26
 sed -i -e '/^EXCLUDED_MODULES=/s/$/ java/' ${DIST}/rules
27 27
 
28
-# use libssl1.0-dev
29
-sed -i -e 's/libssl-dev (<1.1)/libssl1.0-dev/' ${DIST}/control
28
+# libssl1.0-dev conflicts with libcurl4-openssl-dev dependencies
29
+sed -i -e 's/libssl-dev (<<1.1)/libssl-dev/' ${DIST}/control
30 30
 
31 31
 wrap-and-sort -sat -d ${DIST}
32 32
 
... ...
@@ -26,7 +26,7 @@ sed -i -e 's/ java[ ,$]*/ /' ${DIST}/rules
26 26
 sed -i -e '/^EXCLUDED_MODULES=/s/$/ java/' ${DIST}/rules
27 27
 
28 28
 # no libssl-dev 1.0
29
-sed -i -e 's/libssl-dev (<1.1)/libssl-dev/' ${DIST}/control
29
+sed -i -e 's/libssl-dev (<<1.1)/libssl-dev/' ${DIST}/control
30 30
 
31 31
 wrap-and-sort -sat -d ${DIST}
32 32
 
... ...
@@ -26,7 +26,7 @@ sed -i -e 's/ java[ ,$]*/ /' ${DIST}/rules
26 26
 sed -i -e '/^EXCLUDED_MODULES=/s/$/ java/' ${DIST}/rules
27 27
 
28 28
 # no libssl-dev 1.0
29
-sed -i -e 's/libssl-dev (<1.1)/libssl-dev/' ${DIST}/control
29
+sed -i -e 's/libssl-dev (<<1.1)/libssl-dev/' ${DIST}/control
30 30
 
31 31
 wrap-and-sort -sat -d ${DIST}
32 32
 
... ...
@@ -23,7 +23,7 @@ sed -i 's/libmongoc-dev/libbson-dev,\n libmongoc-dev/' \
23 23
 	${DIST}/control
24 24
 
25 25
 # use libssl1.0-dev
26
-sed -i -e 's/libssl-dev (<1.1)/libssl1.0-dev/' ${DIST}/control
26
+sed -i -e 's/libssl-dev (<<1.1)/libssl1.0-dev/' ${DIST}/control
27 27
 
28 28
 wrap-and-sort -sat -d ${DIST}
29 29
 
... ...
@@ -43,7 +43,7 @@ Build-Depends:
43 43
  libsctp-dev,
44 44
  libsnmp-dev,
45 45
  libsqlite3-dev,
46
- libssl-dev (<1.1),
46
+ libssl-dev (<<1.1),
47 47
  libsystemd-dev,
48 48
  libunistring-dev,
49 49
  libval-dev,