Browse code

make: required version is now 3.81

Updated required gnu make version from 3.80 to 3.81, because 3.80
has a bug when dealing with eval inside ifeq/endif
(see
https://savannah.gnu.org/bugs/index.php?func=detailitem&item_id=1516)).
It can be reverted back to 3.80, once workarounds are in place.

Andrei Pelinescu-Onciul authored on 01/06/2009 10:41:01
Showing 1 changed files
... ...
@@ -65,8 +65,10 @@
65 65
 #
66 66
 
67 67
 # check make version
68
-# required 3.80, recommended 3.81
69
-req_ver=3.80
68
+# everything works with 3.80, except evals inside ifeq/endif
69
+# (see https://savannah.gnu.org/bugs/index.php?func=detailitem&item_id=1516).
70
+# recommended 3.81
71
+req_ver=3.81
70 72
 # the check below works for version number of the type x.yy or x.yy.z*
71 73
 # (from the GNU Make Cookbook)
72 74
 ifeq (,$(filter $(req_ver),$(firstword $(sort $(MAKE_VERSION) $(req_ver)))))