This module is considered obsolete.