#!/bin/bash
#
# Target dist: Ubuntu trusty
DIST=trusty

rm -rf ${DIST}
cp -r debian ${DIST}

# No systemd
sed -i -e '/dh-systemd/d' ${DIST}/control
sed -i -e '/dh_systemd/d' ${DIST}/rules
rm ${DIST}/kamailio.service

# No mi_xmlrpc module
sed -i -e '/libxmlrpc-c3-dev/d' -e '/^Package: kamailio-xmlrpc-modules/,/^$/d' \
  ${DIST}/control
sed -i -e 's/ mi_xmlrpc[ ,$]*/ /' ${DIST}/rules
sed -i -e '/^EXTRA_EXCLUDED_MODULES=/s/$/ mi_xmlrpc/' ${DIST}/rules

# use old libfreeradius
sed -i 's/libradcli-dev/libfreeradius-client-dev/' ${DIST}/control
sed -i -e 's/RADCLI/FREERADIUS/' ${DIST}/rules

# no systemd module
sed -i -e '/libsystemd-dev/d' -e '/^Package: kamailio-systemd-modules/,/^$/d' \
  ${DIST}/control
sed -i -e 's/ systemd[ ,$]*/ /' ${DIST}/rules
sed -i -e '/^EXTRA_EXCLUDED_MODULES=/s/$/ systemd/' ${DIST}/rules

# old mysql
sed -i -e 's/default-mysql-client/mysql-client/' \
  -e 's/default-libmysqlclient-dev/libmysqlclient-dev/' ${DIST}/control
echo "kamailio source: build-depends-on-obsolete-package build-depends: libmysqlclient-dev => default-libmysqlclient-dev" >> \
	${DIST}/source.lintian-overrides
echo "kamailio-mysql-modules: depends-on-obsolete-package depends: mysql-client => default-mysql-client" >> \
	${DIST}/kamailio-mysql-modules.lintian-overrides

# no libssl-dev
sed -i -e '/libssl-dev/d' ${DIST}/control

# No geoip2 module
sed -i -e '/libmaxminddb-dev/d' -e '/^Package: kamailio-geoip2-modules/,/^$/d' \
	${DIST}/control
sed -i -e 's/ geoip2[ ,$]*/ /' ${DIST}/rules
sed -i -e '/^EXTRA_EXCLUDED_MODULES=/s/$/ geoip2/' ${DIST}/rules

# No phonenum module
sed -i -e '/libphonenumber-dev/d' -e '/^Package: kamailio-phonenum-modules/,/^$/d' \
	${DIST}/control
sed -i -e 's/ phonenum[ ,$]*/ /' ${DIST}/rules
sed -i -e '/^EXTRA_EXCLUDED_MODULES=/s/$/ phonenum/' ${DIST}/rules

# Mo mongodb
sed -i -e '/libmongoc-dev/d' -e '/^Package: kamailio-mongodb-modules/,/^$/d' \
	${DIST}/control
sed -i -e 's/ mongodb[ ,$]*/ /' ${DIST}/rules
sed -i -e '/^EXTRA_EXCLUDED_MODULES=/s/$/ mongodb/' ${DIST}/rules

# no pkg-config for ruby-dev
sed -i -e '/ruby-dev/d' -e '/^Package: kamailio-ruby-modules/,/^$/d' \
	${DIST}/control
sed -i -e 's/ ruby[ ,$]*/ /' ${DIST}/rules
sed -i -e '/^EXTRA_EXCLUDED_MODULES=/s/$/ ruby/' ${DIST}/rules

# No mqtt module
sed -i -e '/libmosquitto-dev/d' -e '/^Package: kamailio-mqtt-modules/,/^$/d' \
	${DIST}/control
sed -i -e 's/ mqtt[ ,$]*/ /' ${DIST}/rules
sed -i -e '/^EXTRA_EXCLUDED_MODULES=/s/$/ mqtt/' ${DIST}/rules

wrap-and-sort -sat -d ${DIST}

# clean backports scripts
rm -rf ${DIST}/backports
exit 0